NoMethodError

ひさしぶりにmsfupdateをすると、こんなエラーが!

root@bt:/opt/metasploit/msf3# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]
[-] Raised an exception when trying to update:
[-] #
[-]
[-] To update your binary installation, please make
[-] sure the required Metasploit services are running.
/opt/metasploit/apps/pro/engine/update.rb:59:in `
': undefined method `[]' for nil:NilClass (NoMethodError)

ググってみると、どうやらDBが起動してなかったようです。

root@bt:/opt/metasploit/msf3# /etc/init.d/postgresql-8.4 start
* Starting PostgreSQL 8.4 database server
root@bt:/opt/metasploit/msf3#
root@bt:/opt/metasploit/msf3#
root@bt:/opt/metasploit/msf3# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]
[*] Installing update 2013040301...
[*] Querying the update server...

これで問題なくアップデートできました。

root@bt:/opt/metasploit/msf3# msfconsole
_                                                    _
/ \    /\         __                         _   __  /_/ __
| |\  / | _____   \ \           ___   _____ | | /  \ _   \ \
| | \/| | | ___\ |- -|   /\    / __\ | -__/ | || | || | |- -|
|_|   | | | _|__  | |_  / -\ __\ \   | |    | | \__/| |  | |_
|/  |____/  \___\/ /\ \\___/   \/     \__|    |_\  \___\
=[ metasploit v4.5.3-2013040301 [core:4.5 api:1.0]
+ -- --=[ 1084 exploits - 677 auxiliary - 181 post
+ -- --=[ 277 payloads - 29 encoders - 8 nops

よかったよかった。
ほんと大したことない感じのミスでした。
以上

関連する投稿:

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください